Was ist gerade mit dem Mempool los?

Dass der Ersteller dieser Transaktion entweder komplett bescheuert ist oder gerne die Mining Industrie mit Spenden unterstützt. Oder beides.

3 „Gefällt mir“

e380998b3ea8fd0fe18ad9ac9447ab4266769e0c1bbe13493004fadd9f5cabc7

sieht so aus…
Frag mich nicht warum, aber da hat jemand fast die Hälfte des UTXO als Gebühren ausgegeben.

Auch gerade gesehen, 770x überzahlt. Denke da hat jemand die Fees mit dem Betrag vertauscht :wink:

f73286d8702444fbff21acee43d6ecdd83053eb33817cba7e1e732244691fae5

1007x überbezahlt… WARUM??? :wink:
Vielleicht ein Wallet Bug?

Nur mal eine blöde Idee…

Wirtschaftliche Anreize?
Vielleicht schreibt da jemand Verluste ab?
Oder ein Miner, der selbst Geld ausschüttet und die Gebühren wieder aufs eigene Wallet bekommt?

Es kann auch ein Miner gewesen sein.
Wenn er den Block der transaktion selber gemined hat, dann zahlt er sich die Gebühr selber aus. Somit kann man vielleicht die Coin-Historie verschleiern.

Geht aber munter weiter damit:
image

Das sind wahrscheinlich einfach Verwechslungen zwischen sat/vB und sat/KvB. Verschiebt man das Komma 3 Stellen macht die Feerate Sinn.

Die Transaktionen sind doch so in der Blockchain.
Dann würden ja Outputs fehlen.
Die Summe von UTXO und Fee passt ja zum Input.

Ja, ich rede davon dass die Verwechslung auf Nutzer/Wallet Ebene stattfindet, als mögliche Ursache für solche krassen Overpayments.

Man muss nicht unbedingt lange warten. Gestern ging eine Transaktion mit rund 18k Sats Fee relativ schnell durch.

Wieso zeigt mir übrigens mein lokaler Bitcoin RPC Explorer eine andere Mempool Größe an. Aktuell zeigt es rund 13k Transaktionen im Mempool an und auf der Webseite mempool.space sind es rund 30k Transaktionen.
Was für eine Mempool Größe hat bitcoind auf Umbrel?

Weil deine lokale Mempool Größe standardmäßig auf 300 MB gesetzt ist und ab dann (nach Feerate) Transaktionen ablehnt. Das kannst du natürlich auch selbst anpassen.

Wer dieses Limit anhebt (z.B. mempool.space) sammelt Transaktionen die von anderen halt aussortiert werden. Sind die 300 MB irgendwann wieder unterschritten können auch die überschüssigen Transaktionen wieder unter allen Nodes ausgetauscht werden.

Da dieser Standardwert von einem Großteil der Nodes auch umgesetzt wird berücksichtigt die Anzeige von den großen Explorern das auch z.B. um die minimale Feerate wie unten in den Screenshots entsprechend anzuzeigen.

mempool.space:

Meine Node:

Jetzt ist grade eine wunderbare Zeit sich mit Lightning zu beschäftigen. (Günstigere Transaktionen)
Ich denke in Zukunft (20Jahre) wird der Mempool dauerhaft so voll sein.

Ich sehe bereits, wie auch die LND Routings meiner Node steigen :smiley:

1 „Gefällt mir“

In Umbrel wird angezeigt das mein Mempool nur 139 MB groß ist. Sollte das nicht voll sein also 300 MB?

Kenne mich mit Umbrel nicht aus, aber SSH mal auf deine Node und schau in ~/umbrel/bitcoin/bitcoin.conf nach dem maxmempool Parameter.

Müsste aber standardmäßig auf 300 gesetzt sein.

Oder mach mal bitcoin-cli getmempoolinfo.

Leider ist der Pfad so nicht verfügbar und im gesamten umbrel Ordner gibt es keine Datei namens bitcoin.conf. Ich habe Umbrel auf Debian über den umbrell.sh Script installiert.

Das hat funktioniert. Die Ausgabe:

{
  "loaded": true,
  "size": 16110,
  "bytes": 142464422,
  "usage": 299984416,
  "total_fee": 19.54184405,
  "maxmempool": 300000000,
  "mempoolminfee": 0.00014512,
  "minrelaytxfee": 0.00001000,
  "unbroadcastcount": 0
}

Es sind also 300 MB. Aber wenn man in Umbrel die Bitcoin Node App öffnet wird dort viel weniger als 300 MB angezeigt.

Hast du schon einen Neustart gemacht?

(Sorry, den Pfad hatte ich aus dem Umbrel Forum gefischt, ist wohl nicht mehr aktuell…)

@DeTec
Die Datei kannst du auch suchen lassen, mit den folgenden zwei Commands.
cd /
sudo find -name bitcoin.conf

Habe ich jetzt getan. Das Mempool wuchs und stagniert jetzt erneut bei ca. 140 MB.

Habe ich getan. Die Datei existiert im gesamten Dateisystem nicht. Und anscheinend ist das normal so?

Der Ordner wo die conf Datei sein sollte ist unter umbrel/app-data/bitcoin/data/bitcoin/. Aber es gibt dort einfach keine .conf Datei. Entweder hat das etwas mit Docker zu tun (kenne mich damit nicht aus) oder die Einstellungen werden beim Start von bitcoind als Parameter übergeben.

@DeTec

prober es nochmal mit sudo habe ich nachträglich geändert. Ohne das geht es bei mir auch nicht.

cd /
sudo find -name bitcoin.conf

Die Datei muss es doch geben.