Zeus Wallet mit eigener Raspiblitz Node verbinden

Hallo Community,
ich bin gerade dabei die Zeus Wallet mit meiner Raspiblitz Lightning Node zu verbinden. Dazu kann ich auf meinem Raspiblitz und der Zeus App folgendes auswählen:
Zeus to C-LightningRESTR
Zeus to Sparko
was genau heißt das denn und was sind die Unterschiede zwischen den beiden? Hab online nigs gefunden was mir das erklären könnte. Weiß hier jemand bescheid?

Hallo Martin!

Ja, mir geht es gerade genau so.
Alle Anleitungen scheinen für LND gemacht zu sein.
In mach einem Video wird die Option Zeus_IOS gezeigt. Wie bekommt man die Option?

Kann hier jemand helfen?

Gruß Seeb

Hy Seeb,
mittlerweile hab ich es geschafft.
Ich hab C-lightning REST auf Zeus ausgewählt. Mit Sparko hab ich es nicht geschafft.
Dann hab ich den Host rein kopiert
Den REST Port eingetragen
Und den Macaroon Wert.
Wenn Zeus das alles hat, konnte sich die App mit meiner Node verbinden.

Vielleicht klappt es ja bei dir auch auf dem Weg.

Aber ich muss sagen ich bin mit Zeus nicht wirklich zufrieden. Payments kann man damit problemlos machen.
Aber wenn ich die Fees meiner Channelsanschaue, steht überall 1 msat als Base Fee und 1 PPM drin. Mit RTL hab ich aber ganz andere Fees eingetragen.
Auch das Ändern von Fees funktioniert mit Zeus bei mir nicht.

Vielleicht hilft dir die Info etwas

1 „Gefällt mir“

Habe es genauso gemacht, wie von dir beschrieben aber bekomme keine Verbindung.
Error: SOCKS: Connection refused

Habe bisher nur Erfahrung mit Zeus unter LND und das scheint ein bekanntes Problem zu sein. Die ganze App ist noch zu wesentlichen Teilen Work in Progress und wird sicherlich bei Zeiten gefixed. Die App kürzlich erst ein großes Design Update bekommen. Geht also munter weiter

Hast du in der Zeus App Port 443 und Macaroon angegeben. Dann müsste es mit dem Raspi klappen.

Vielen Dank @SirSir, mit Port 443 hat es geklappt. Im Raspiblitz Menü wurde mir Port 6100 angezeigt und das war ne Sackgasse :sweat_smile:

1 „Gefällt mir“

ja das ist etwas irritierend… ich hab auch etwas rum probiert mit den Ports und Angaben bis es funktioniert hat.
Ist alles etwas frustrierend bis es läuft. Aktuell will ich RTL updaten. Das Update läuft zwar durch, aber ich kann immer noch nur die alte Version im Browser öffnen :joy:

Bin gespannt wie es in ein paar Jahren aussieht. Da kann wahrscheinlich keiner mehr verstehen was wir gerade für Probleme haben

Hi zusammen!

ja, vielen Dank! Bei mir hat die Anbindung dann auch geklappt.
443 braucht man, wenn man die Anbindung über die öffentliche IP oder TOR Adresse macht.
Wenn man die App nur intern in seinem eigenen Netz nutzen will, dann kann man auch die interne IP des Raspiblitz nutzen und muss dann 6100 als Port nehmen. (so zumindest meine Erfahrung)

RTL Update auf 0.12.2 habe ich auch schon versucht. Bleibt im Browser dann aber auf 0.12.1.

Gruß Seeb

Hi Martin, ich könnte bei der Zeus app deine Hilfe gebrauchen. Ich bin offensichtlich Anfänger und komme mit den Begriffen nicht nicht klar. Da ich auf meinem Raspi c-Lightning aktiviert habe geht das mit dem Scan bei der Zeus App nicht. Ich muss manuell eingeben. Und bräuchte ich bitte Support was das alles ist und wo ich das bei mir finde. Schon mal ein Danke im Voraus.

Ich bin zwar nicht Martin😊 aber helfe Dir gerne. Wenn Du bei dem QR Code bist dann gib in der Zeus App manuell das ein was da steht. Wichtig ist das Du anstatt des angebenen Port 443 verwendest und die Macaroon angibst.

Hi, ein Dankeschön an dich für deine Hilfe :+1: Ich habe bei Node Schnittstelle x-Lightning Rest eingegeben. Bei Host steht bei mir localhost. Ist das korrekt? Die Rest Port Nr. 443/ …habe ich schon gefunden. Bei Macaroon steht OA. Keine Ahnung was ein Macaroon ist :see_no_evil:

Soweit alles richtig. Wenn du bei dem QR Code bist einmal enter und dann steht über dem QR Code der Macaroon. Den einmal kopieren und in der Zeus App bei Macaroon eintragen

Ahhh ok. Mache ich nachher wenn ich zu Hause bin und berichte dann :point_up::grimacing:

Hat soweit ganz gut geklappt. Aber jetzt bekomme ich aber immer eine Errormeldung 404


Vielleicht hilft das. Ich hab mal meine gespeicherten Einstellungen kopiert. Ich hab alles händisch eingetragen. Ich bin der Meinung den Host hab ich nicht selbst einfügen müssen.
Die Infos hab ich über RTL zusammen gesucht und dann eingetippt. Ich hab als erstes Spark als Node Schnittstelle versucht. Das hat aber nicht funktioniert, obwohl es auf meinem Raspiblitz eine Option war.

Zu Zeus noch ein paar Worte: Das Design ist seit dem neuesten Update echt cool. Und Zahlungen kann ich über die App auch problemlos machen. Aber manchmal wird mir die Onchain Balance nicht richtig angezeigt und die Channel Fees kann ich auch nicht über Zeus ändern. Vielleicht hab ich noch etwas in meinen Einstellungen falsch.

1 „Gefällt mir“

Danke für deine Hilfe. Sie läuft. :point_up::grimacing:. Ich habe deinen Eintrag noch mal durch gelesen und diejenigen da….mein Host war nicht richtig.

Ich habe eben meine Zeus App mit Citadel verbunden. Hier funktioniert auch Port 8080 wie es in den Einstellungen steht. Macht das irgendeinen unterschied welchen Port ich hole. Über Tor komme ich auch problemlos rein.


Guten Abend. Ich benötige wieder mal deine Hilfe. :see_no_evil:Meine Zeus App zickt im Moment rum. Es ging alles und am nächsten Tag nicht mehr Error Meldung. Hast du diese Meldung schon mal gesehen? Habe ich am Raspi eventuell etwas verstellt sodass jetzt was fehlt? Ich habe die App schon komplett runtergeschmissen und neu aufgesetzt mit dem gleichen Erfolg. Ähnlich läuft es mit der Fully App …. mit QR Code aufgesetzt aber sie verbindet sich wohl nicht. Grüße JoFi72

selbes Problem bei mir, seid 3-Tagen.

Ich habe die neuste Zeus Version von Github. Habe damit keine Probleme. Einfach mal auf Neustart in der APP klicken.
Hast du mal probiert deine Node neuzustarten?