Gehäuse für Raspberry Pi 4 für Node

Hi Leute,

da ich mehrere Nodes am Laufen habe, habe ich mich etwas intensiver mit dem Thema der passenden Gehäuse beschäftigt. Das Gehäuse von Roman sieht natürlich beeindruckend aus, schon alleine wegen der Größe, aber es besitzt halt auch den ein oder anderen Nachteil meiner Meinung nach. Deshalb habe ich mich durch die verschiedenen Gehäuse mal etwas durchgewühlt, habe verschiedene bestellt und viele davon aber auch schnell wieder verkauft.
Ich bin ein wenig Hardwarefetischist und auch wenn der ARM-A72-Prozessor erst ab 80°C anfängt sich runter zu takten, mag ich es überhaupt nicht. Kühlere Temperaturen = mehr Leistungsreserven und längere Lebensdauer. Und damit meine ich nicht nur unbedingt den Prozessor an sich denn dieser ist ja durchaus auf diese Temperatur ausgelegt und designed. Aber zum Beispiel die ganzen Kondensatoren, Spannungswandler usw. leben länger, je kühler sie im Betrieb gehalten werden.
Und dann ist es mir persönlich noch wichtig nicht so einen Klotz im Regal liegen zu haben. Natürlich kann das auch sehr charmant sein wenn man einen Raspberry offen an der Wand hängen hat wo man jeden Chip, jede Verbindung usw. sieht. Aber entweder mache ich nen Show-Zweck draus und suche mir wirklich etwas wo ich den nackten Raspi an die Wand dübel, daneben die SATA-Platte und dann evtl. noch ein oder zwei geklebte Kühlkörper auf die Chips oder aber ich suche mir ein wirklich schönes, praktisches aber vor allem funktionelles Gehäuse.

Und genau dieses habe ich im Argon One M.2 gefunden.
Das Oberteil des Gehäuses ist komplett aus Aluminium, besitzt 2 direkte (massive) Verbindungen zum Prozessor und zum RAM um die Wärme an das Gehäuse abzuführen, einen Lüfter, eine Adapterplatine um aus den Micro-HDMI Port normale HDMI-Ports zu bekommen und diese auch schön von hinten zu verbinden. Es liegen auch Wärmeleitpads bei, welche den Kontakt von CPU, RAM und Gehäuse verbessern. Der Lüfter lässt sich durch die Installation eines kleinen Skrips auf verschiedene Temperaturen konfigurieren.
Allerdings habe ich be Verwendung dieses Gehäuses selten Temperaturen von über 50°C auf meinen Raspberries gesehen. Selbst während dem validieren der kompletten Blockchain liegen die Temps meistens unter 50°C.
Zusätzlich hat dieses Gehäuse unter dem Raspberry Pi 4 noch eine Platine wo man eine M.2 SATA SSD verbauen und diese mit einer mitgelieferten USB-Brücke mit dem Raspberry zu verbinden. Dadurch bekommt man alles in einem Gehäuse unter und es sieht meiner Meinung nach auch noch sehr schick aus.

Einziger Punkt auf den man achten muss: Die M.2 SSD darf keine NVMe sein, auch wenn der verbaute Slot auf der Platine etwas anderes aussagt. Es muss zwingend eine SATA M.2 SSD sein. Diese hat auch noch einen weiteren Vorteil: Sie ist um einiges günstiger als eine NVMe.

Auch der Touchscreen passt noch oben auf das Gehäuse drauf, da die PINs unter einer magnetisch festgehaltenen Klappe auf die Oberseite geführt wurden.

Hier jetzt noch ein paar Fotos falls es jemanden interessieren sollte:







1 „Gefällt mir“

Kann nach 9 Monaten Dauerbetrieb als Umbrel-node inkl. Lightning, inkl. ein paar zusätzlicher apps von Herzen folgendes Gehäuse OHNE VENTILATOR empfehlen.

https://joy-it.net/de/products/RB-AlucaseP4+08

Mein Raspi hatte lt. internem Sensor nie mehr als 47°C (im Sommer wo die Lufttemperatur im Zimmer schon über 30°C war) … jetzt in der Heizperiode, wo die Zimmertempertur bei 22-23°C liegt, meldet der Raspisensor 41°C

Hab mir das Gehäuse ursprünglich gekauft, weil ich einerseits Strom sparen wollte, und andererseits auch testen wollte, ob die passive Kühlung für den Raspi als Lightning-Node ausreichend ist, und ich damit ohne Gebläselärm auskomme.

Die 2 TB SSD liegt in einem portablem Gehäuse direkt daneben - könnte auch drunter liegen, aber dann meldet der Raspi Sensor 3-5°C höhere Temperaturen, deshalb liegt die SSD bei mir daneben. :slight_smile:

3 „Gefällt mir“

Kommt mir irgendwie bekannt vor …

… und ich habe die gleichen Erfahrungen bzgl. Temperatur gemacht!

Grüße DeepThought

2 „Gefällt mir“

Auch ein sehr cooles Gehäuse, ein Ähnliches Model hatte ich lustigerweise auch bestellt gehabt und die Temperaturen waren auch wirklich gut. Gefallen hat mir einzig nur nicht dass die Festplatte daneben oder darunter liegt und mit eben wieder mit einem Kabel angebunden werden muss (aber das ist definitiv Geschmacksache) und dass die PINs zum aufstecken eines Displays nicht mehr erreichbar waren weil das Gehäuse keine Öffnung an der entsprechenden Stelle hatte. Wie ist das denn bei dem Joy-IT gelöst? Kommt man da noch ran?
Was zusätzlich aber für Frust sorgen kann ist das man wieder spezielle Kabel zum Anschluss braucht. Ich kann mich noch dran erinnern dass ich den RasPi mit in den Urlaub genommen habe und die Adapter von Micro HDMI auf HDMI zu Hause habe liegen gelassen habe…was für ein Frust.

Ganz kurz noch am Rande: Der Lüfter vom Argon ist bei mir unter 55°C komplett aus, das Gehäuse ist dann komplett passive gekühlt. Man kann den Lüfter konfigurieren.

Das von mir genutzte Gehäuse „verschließt“ die PINs … aber es gibt ein ähnliches passives Kühlmodul-Gehäuse, dass die PINs und auch die übrigen Anschlüsse absichtlich „freistellt“ … vermute, dass die Kühlung ähnlich gut funktioniert, aber ich kann dazu nichts näheres sagen, da ich es selbst nie gekauft habe, und daher keine Erfahrungswerte habe. Wenn ich aber künftig wieder mal ein Raspi-Projekt mache, wo ich auch Zugang zu den PINs benötige, würde ich dieses Modell probieren.
https://joy-it.net/de/products/RB-AlucaseP4+07

1 „Gefällt mir“

Mein Raspi4 immer bei 80°C trotz Alugehäuse. Habe mir dein massives Joy-it gleich mal bestellt. Gibts z.B. bei Alternate und Voelkner

1 „Gefällt mir“

Tolles Gehäuse, damit ersetze ich mein aktuelles :slightly_smiling_face:

Vielen Dank fürs sharen

1 „Gefällt mir“

Hey kann mir jemand helfen die passende SSD dazu zu finden. Ich hatte mir diese hier bestellt: 1TB WD Blue M.2 2280 SATA (ist ja wie @Repairman sagt eine M.2 SATA). Allerdings sagt mein Gerät „Waiting for HDD/SDD“.

Der Anschluss auf dem Board hat ja auch nur eine Einkerbung und nicht wie die SSD selbst zwei.

Hallo und Herzlich willkommen hier im Forum.

Welches Gehäuse hast du dir denn bestellt? Das Argon One M.2?
Die WD hatte ich am Anfang zum spielen in der 500GB Version im Einsatz und sie funktionierte auch ohne Probleme.
War die SSD brandneu? Wenn das so ist, musst du sie zuerst mit z.B. gparted formatieren.
Ich gehe jetzt einfach mal ganz frech davon aus dass du die USB-Brücke angesteckt hast.
Du kannst die SSD auch an einem anderen PC formatieren.

Wie schon oben beschrieben: Das ist scheinbar ein Fehler vom Hersteller, der Slot wäre eigentlich der Richtige für eine NVMe, diese wird aber definitiv nicht erkannt.
Zur Zeit habe ich eine 2TB SATA SSD WD Red drin und alles läuft tip top.