Keine Verbindung zum Electrum Rust Server

Hallo,

bin neu hier im Forum und hab gleich mal eine techn. Problem.

Ich habe eine Raspibliz mit Electrum Rust Server aufgesetzt. Aus meiner Sicht läuft alles.

STATUS ELECTRS SERVICE

configured=1
serviceInstalled=1
serviceRunning=1
tipSynced=1
electrumResponding=1
initialSynced=1
localIP=‚192.168.178.123‘
portTCP=‚50001‘
localTCPPortActive=1
publicTCPPortAnswering=0
portHTTP=‚50002‘
localHTTPPortActive=1
publicHTTPPortAnswering=0
TORrunning=1
nginxTest=1

Wenn ich versuche mit meiner Electrum Wallet (Windows im selben LAN) auf diesen Server zu verbinden, zeigt die Wallet „nicht verbunden“ an, mit jedem anderen Electrum Server der mir angeboten wird funktioniert es.

Irgend eine Idee was ich falsch mache?

Hi Herzlich willkommen!

Meine Idee wär zu schauen ob der Electrum rust eingehende Verbindungen zulässt oder
der Pi blockiert eingehende Verbindungen zum Beispiel durch eine firewall?

Du hast Tor aktiviert. Wie hast Du die Verbindung über Tor realisiert ?

Ja, ich habe Tor aktiviert, aber ich bin in selben Netz und gehen über die lokale IP an den Server. Alle anderen Funktionen SSH, Lightening Wallet usw. funktionieren lokal.

Die Lightning Wallet ist auch über Tor von außen erreichbar.

Naja, würde mit nmap mal schauen welche Ports erreichbar sind und ob der Port erreichbar ist.
Für diese Fragen wende Dich bestenfalls an https://telegram.me/raspiblitz_DE

Danke für Deine Rückmeldung, der Port 50002 ist (soweit ich das Protokoll von nmap verstehe) offen.

PORT STATE SERVICE VERSION
22/tcp open ssh OpenSSH 7.9p1 Raspbian 10+deb10u2 (protocol 2.0)
80/tcp open http nginx 1.14.2
443/tcp closed https
3000/tcp open http Node.js Express framework
3001/tcp open ssl/http nginx 1.14.2
8080/tcp open http-proxy Ncat http proxy (Nmap 4.85BETA1 or later)
8333/tcp closed bitcoin
10009/tcp open ssl/swdtp-sv?
50001/tcp closed unknown
50002/tcp open ssl/iiimsf?

Ich werd mich mal parall in der Telegramgruppe umsehen.